Como calcular a idade de uma pessoa?

Para calcular a idade atualizada de uma pessoa a partir de sua data de nascimento, utilizaremos as funções HOJE(), DIA(núm_série), MÊS(núm_série), ANO(núm_série) e DATA(ano; mês; dia):

Se a data de nascimento estiver na célula A1, você pode utilizar a fórmula a seguir para chegar à idade correspondente:

=SE(DATA(ANO(HOJE());MÊS(HOJE());DIA(HOJE()))>=DATA(ANO(HOJE());MÊS(A1);DIA(A1));ANO(HOJE())-ANO(A1);ANO(HOJE())-1-ANO(A1))

Interpretação da fórmula acima: se a data de hoje é mais recente ou coincide com a data de aniversário do nascimento, subtrair ano de nascimento do ano atual. Senão, subtrair ano de nascimento do ano anterior.