Como alternar o valor de uma célula de acordo com um determinado critério?

Para quem está iniciando no uso de planilhas em geral, a função que iremos apresentar a seguir é essencial e está presente em praticamente todas as planilhas que envolvam algum cálculo.

Imagine que você tenha recebido um cadastro em ordem alfabética contendo 1.000 inscritos e precise dividi-los em apenas duas listas, pelo critério do número da inscrição. Se o número da inscrição for menor ou igual a 100, os candidatos ficarão na lista SELECIONADOS. Os demais ficarão na lista EM ESPERA.

Veja como ficará fácil essa divisão, mesmo com números de inscrição misturados no cadastro, através da função abaixo.

Função SE(teste_lógico;[valor_se_verdadeiro];[valor_se_falso])

A função SE() testa um determinado critério (teste_lógico) e retorna um valor de acordo com o resultado do teste. Se o teste lógico retornar VERDADEIRO, a função assumirá o valor que você inserir após o critério, no argumento valor_se_verdadeiro. Se o teste retornar FALSO, a função receberá o valor_se_falso que você determinar.

Assim, SE(4>2;”quatro é maior que dois”;”quatro é menor que 2″) retornará quatro é maior que dois.

Vale observar que quando você não preenche os argumentos envolvidos por colchetes (“[valor_se_verdadeiro]”, “[valor_se_falso]”), a função retornará as palavras-chaves VERDADEIRO e FALSO, conforme o caso.

Agora, veja como seria a solução para a lista de inscrição que mencionamos no início:

A B C
1 Nº Inscrição Nome do candidato Lista
2 130 ALBERTO PEREIRA =SE(A2<=100;”SELECIONADOS”;”EM ESPERA”)
3 80 ANTONIO FERREIRA =SE(A3<=100;”SELECIONADOS”;”EM ESPERA”)
4 220 ANTONIO SANTOS =SE(A4<=100;”SELECIONADOS”;”EM ESPERA”)
5 5 BRUNO DA SILVA =SE(A5<=100;”SELECIONADOS”;”EM ESPERA”)
6 100 BRUNO FERREIRA =SE(A6<=100;”SELECIONADOS”;”EM ESPERA”)

Como resultado, você certamente encontrará o seguinte:

A B C
1 Nº Inscrição Nome do candidato Lista
2 130 ALBERTO PEREIRA EM ESPERA
3 80 ANTONIO FERREIRA SELECIONADOS
4 220 ANTONIO SANTOS EM ESPERA
5 5 BRUNO DA SILVA SELECIONADOS
6 100 BRUNO FERREIRA SELECIONADOS