Como inverter o resultado de uma expressão lógica?

Antes de prosseguir por aqui, seria bom checar se você já deu uma lida em nossa dica sobre operadores lógicos.

Para quem já está um pouco mais acostumado aos princípios básicos de lógica proposicional, não é novidade que o inverso do operador <= (menor que ou igual a) seja o operador > (maior que), tanto quanto o inverso do operador = (igual a) seja o operador <> (diferente de) e assim por diante.

No entanto, os editores de planilhas possuem algumas funções lógicas para as quais não existem funções inversas. Por exemplo, a função ÉNÚM() retorna VERDADEIRO quando o argumento representa um valor numérico. Seu inverso poderia ser uma suposta função NÃOÉNUM(), que retornasse FALSO quando recebesse um valor numérico como argumento. Mas tal função não existe.

Imagine agora que precisemos testar se o valor de uma célula é do tipo ERRO antes de utilizá-la em outra célula. A fórmula ficaria assim: SE(ÉERRO(A1)=FALSO;A1*1,5;”Valor não disponível”). Ou seja, se a função ÉERRO() retornar FALSO significa que o valor de A1 poderá ser utilizado para o cálculo.

Em vez dessa construção, que também está correta, você poderia optar por inverter o resultado de ÉERRO() para que o argumento da função SE() ficasse VERDADEIRO sempre que ÉERRO() retornasse FALSO.

A função a seguir nos ajuda a inverter o resultado de uma expressão lógica quando isso for facilitar a descrição de nosso teste lógico.

Função NÃO(lógico)

A função NÃO() retorna o inverso da expressão lógica que lhe for passada como argumento. Sabemos que 1<1 retornará FALSO, mas se você testar NÃO(1<1), essa expressão retornará VERDADEIRO.

Veja mais exemplos com a função ÉERRO() e a função ÉNUM() a seguir. Repare como a leitura das fórmulas fica mais fácil (“se não é erro…”, “se não é numérico”):

A B
1 #REF! =SE(NÃO(ÉERRO(A1));A1*1,5;”Valor indisponível”)
2 150,00 =SE(NÃO(ÉERRO(A2));A2*1,5;”Valor indisponível”)
3 ABCD =SE(NÃO(ÉNUM(A3));”Valor incompatível”;A3/100)
4 500 =SE(NÃO(ÉNUM(A4));”Valor incompatível”;A4/100)

Como resultado, você certamente encontrará o seguinte:

A B
1 #REF! Valor indisponível
2 R$ 150,00 R$ 225,00
3 ABCD Valor incompatível
3 500 5