Como checar se o texto de uma célula é exatamente igual a uma célula ou texto definido?

Quando utilizamos precisamos comparar duas sequências de texto, um cuidado importante deve ser tomado quanto à necessidade de diferenciar letras maiúsculas de letras minúsculas.

Utilizando o operador “=” (igual), as células de texto A1 e A2, contendo respectivamente “Professor” e “professor”, retornarão o valor VERDADEIRO quando comparadas no exemplo a seguir:

=SE(A1=A2; “EDUCAÇÃO”; “OUTROS”)

Para determinadas conferências de valores de texto, essa comparação será suficiente. Em outros casos, no entanto, pode-se desejar diferenciar o texto “XrT6oP” de “XRT6OP”, como quando temos um código ou senha que precisa ser informado exatamente daquele jeito para haver o batimento.

Função EXATO(texto ou célula;texto ou célula)

Utilize a função EXATO() para obter VERDADEIRO apenas quando a sequência texto1 for exatamente idêntica a texto2. Na fórmula acima, ficaria assim:

=SE(EXATO(A1;A2); “EDUCAÇÃO”; “OUTROS”)

Veja um exemplo de utilização da fórmula abaixo com o operador “=” (igual):

A B C
1 Médico professor =SE(A1=B1;”EDUCAÇÃO”;”OUTRAS”)
2 professor professor =SE(A2=B2;”EDUCAÇÃO”;”OUTRAS”)
3 PROFESSOR professor =SE(A3=B3;”EDUCAÇÃO”;”OUTRAS”)

Que retornará:

A B C
1 Médico professor OUTRAS
2 professor professor EDUCAÇÃO
3 PROFESSOR professor EDUCAÇÃO

Veja um exemplo de utilização da fórmula abaixo com a função EXATO():

A B C
1 XpTO4531 XPTO4532 =SE(EXATO(A1;B1);”IGUAL”;”DIFERENTE”)
2 XPtO4532 XPTO4532 =SE(EXATO(A2;B2);”IGUAL”;”DIFERENTE”)
3 XPTO4532 XPTO4532 =SE(EXATO(A3;B3);”IGUAL”;”DIFERENTE”)

Que retornará:

A B C
1 XpTO4531 XPTO4532 DIFERENTE
2 XPtO4532 XPTO4532 DIFERENTE
3 XPTO4532 XPTO4532 IGUAL